entmake


(entmake  [ entityData ] )

This function created a new object or entity in the current drawing.

Arguments

entityData  (optional) definition data (assoc list) to define the new object or entity

Return

entityData  if successful, NIL otherwise;
returns the block name, if entmake is used to finish a block definition (entmake of ENDBLK object);
returns NIL, if entityData is omitted

Example


Remarks

entmake creates both graphical and non-graphical objects and entities;
see (entget) function for the definition data list
see (entmakex) function, which is mostly more efficient



©  Bricsys NV. All rights reserved.