mapcar


(mapcar  function [ listA [ listB ... [ listN ]]] )

This function applies the arguments from listA, listB ... listN as arguments for function in a loop, and returns the list of results from each loop evaluation.

Arguments

listA  list of arguments (first argument for function)

listB  list of arguments (second argument for function)
:
listN  list of arguments (last argument for function)

Return

list of result values, from evaluation function with the arguments from the lists

Example

(mapcar 'strcat '("this " "but " "mostly ") '("is " "also " "it ") '("ok" "nice" "fails"))
returns
("this is ok" "but also nice" "mostly it fails")

Remarks

for function : any built-in AutoLISP function, a lambda expression (anonymous defun), a user-defined defun can be used



©  Bricsys NV. All rights reserved.