menucmd


(menucmd  expr)

This function evaluates a menu expression string expr.

Arguments

expr  any string, representing a valid menu expression

syntax is : "menupart=value"

supported values for "menupart" :

Bn-: "BUTTONS" menus 1 - 4
An : "AUX" menus 1 - 4
Pn : "PullDown" menus 1 - 31, index 0 specifies the mouse shortcut menu
In : "Image" menus
Sn : "SCREEN" menu (obsolete, no longer supported)
Tn : "TABLET" menus 1 - 4
M : expression string (DIESEL)
G : group.name : specifies a particular menu part by "group" and "name" identifiers

Return

always returns NIL

Example

(menucmd "P0=*")  shows the mouse shortcut menu

Remarks

DIESEL expression strings are also allowed, to be used in conjunction with $M menu expressions



©  Bricsys NV. All rights reserved.