vl-bb-set


(vl-bb-set 'varName value)

This function stores the value for varName in the Lisp "BlackBoard".

Arguments

varName  (symbol) name of a Lisp variable
value  (any Lisp value) the value to be stored in the Lisp "BlackBoard" for varName

Return

returns value

Example

(vl-bb-set 'MyInstallPath "C:/Apps/Tools/")
returns "C:/Apps/Tools/"

Remarks

the Lisp "BlackBoard" is global to all open drawings and all loaded Lisp code;
see (vl-bb-ref)



©  Bricsys NV. All rights reserved.