vl-every


(vl-every comparator listA [ listB [ listC ] ... ] ] ] )

This function compares all corresponding items of listA with those from listB and listC ... using the comparator function.

Arguments

comparator  (function, lambda, symbol) the comparator function to be used;
- a DEFUN name like 'MyComp
- (lambda ...)
- (function ...)
listA  (list) first list to compare the entries against the other lists
listB  (list) next list to compare the entries against the other lists
listC  (list) next list to compare the entries against the other lists
  :

Return

T if comparator function returns non-NIL for each comparison; NIL otherwise

Example

(vl-every '< '(1 2 3) '(2 3 4) '(3 4 5))  T
(vl-every '< '(1 2 3) '(2 0 4) '(3 4 5))  NIL

Remarks

processing the comparison of list items stops if any list has no more items, or if any comparison returns NIL



©  Bricsys NV. All rights reserved.