vl-remove-if


(vl-remove-if comparator lst)

This function removes all items from lst list, which match the comparator function.

Arguments

comparator  (symbol, function, lambda) function used for the boolean comparison; must return NIL resp. non-NIL
lst  (list) any list of items

Return

(list) all items of lst, which do not match the comparator function (that is, comparator function returns NIL)

Example

(vl-remove-if '(lambda (x) (<= x 5)) '(1 2 3 4 5 6 7 8 9 10))
returns (6 7 8 9 10)

Remarks




©  Bricsys NV. All rights reserved.