vlax-invoke-method


(vlax-invoke-method vlaObject method [ arg1 [ arg2 ] ] )

This function calls the method function on the vlaObject object.

Arguments

vlaObject  (vla-object) the COM object to query for property value
method  (string or symbol) the name of the method to be called
arg1  (optional)  argument specific for method
arg2  (optional)  argument specific for method
:

Return

returns NIL (mostly) or a method-specific result

Example

last entity is a LINE<1,1,1> to <10,10,10> :
(setq ent (vlax-ename->vla-object (entlast)))  #<VLA-OBJECT IAcadLine 000000004E8E3928>
(vlax-invoke-method ent 'StartPoint)  returns #<variant 8197 ...>  (Variant containing a SafeArray of 3 double values)

Remarks




©  Bricsys NV. All rights reserved.