vlax-ldata-put


(vlax-ldata-put dictionary key value [ private ] )

This function stores the LISP value under key in dictionary.

Arguments

dictionary  (vla-object | ename | string)  specifies the dictionary to store the LISP data
key  (string)  the dictionary key used to address the LISP data
value  (any suitable Lisp value, optional)  value to be stored under key
private  (T/NIL)  if specified as non-NIL, and called from "Separate Namespace" code, the value is marked as "private"

Return

returns value if successful (or triggers an error)

Example

(vlax-ldata-put MyDicionary "status" "ok")  "ok"

Remarks

key string is case-insensitive;
see (vlax-ldata-get) and (vlax-ldata-test) functions



©  Bricsys NV. All rights reserved.