vlax-map-collection


(vlax-map-collection vlaObject function)

This function applies the specified function to all objects of the vlaObject collection.

Arguments

vlaCollection  (VLA-Object) any COM collection object
function  (symbol) name of a Lisp function (native or DEFUN or LAMBDA) to be called

Return

the vlaObject argument

Example

(setq cad (vlax-get-acad-object))  #<VLA-OBJECT IAcadApplication 000000002E425B80>
(setq doc (vla-get-activedocument cad))  #<VLA-OBJECT IAcadDocument 000000002EBD4478>
(vlax-map-collection (vla-get-layers doc) '(lambda (x) (print x)(princ)))

#<VLA-OBJECT IAcadLayer 0000000039DDF8F0>
#<VLA-OBJECT IAcadLayer 0000000039DDE8F0>
#<VLA-OBJECT IAcadLayer 0000000039DDF670>
#<VLA-OBJECT IAcadLayer 0000000039DDF6F0>

Remarks




©  Bricsys NV. All rights reserved.