vle-safearray->list


(vle-safearray->list  safearray)

creates a normal list of items from given SafeArray safearray

Arguments

safearray   the SAFEARRAY to be returned as list

Return

list of items, or NIL if safearray is empty

Example

(vle-safearray->list sa)
returns  (<#IDispatch object> <#IDispatch object> ...) or NIL

Alias


Remarks

other than the normal (vlax-safearray->list), this function does not trigger an error if the SafeArray is empty (which is normal + valid for any SafeArray)



©  Bricsys NV. All rights reserved.