vle-entget-massoc


(vle-entget-massoc  dxfCode  ename)

returns a list of all values using same key 'dxfCode' in the (entget) list of an entity 'ename'

Arguments

dxfCode  key to be used to parse the (entget) list of 'ename'

ename  entity name

Return

a list of all cdr values of assoc items with key 'dxfCode';
all values are in their original sequence

Example

assume 'pline' to be a LWPOLYLINE with 4 vertices
(vle-entget-massoc 10 pline)
=>  ((11.08 76.272)(14.54 14.2)(23.45 16.71)(26.18 11.62)(19.84 5.064))

Alias


Remarks

functional identical with : (vle-list-massoc  dxfCode  (entget ename)), but with higher performance



©  Bricsys NV. All rights reserved.