vle-int64to32


(vle-int64to32  intVal)

truncates a given integer value to be in 32 bit range
if input value is above 32 bit range (a 64 bit value) then this is truncated to a 32 bit value, to match the behaviour of other CAD systems using 32 bit integers even in x64 builds

Arguments

intVal  any integer value

Return

always returns a 32 bit integer value

Example

(vle-int64to32 (* 10 268435456))
returns -1610612736 instead of 2684354560

Alias


Remarks

this is effective only with Bricscad x64, otherwise it does nothing;
as BricsCAD x64 allows 64 bit integers, there is a minor conflict in compatibility with other CAD systems here;
if a Lisp application needs that incorrect behaviour of other CAD systems, then this function can help as workaround



©  Bricsys NV. All rights reserved.