vle-list-massoc


(vle-list-massoc  key  lst)

returns a list of all values using same 'key' in assoc-list 'lst'

Arguments

key  key to be used to parse the assoc list

lst  assoc list, may contain multiple items with same key

Return

a list containing all cdr values of assoc items with key 'key';
the list may contain multiple assoc items with key 'key';
returned list contains all values in original sequence

Example

(setq lst '((1 . "a")(2 . "b")(1 . 11)(2 . 22)))
(vle-list-massoc 1 lst) => ("a" 11)
(vle-list-massoc 2 lst) => ("b" 22)

Alias


Remarks




©  Bricsys NV. All rights reserved.