vlr-pers
(vlr-pers reactor)
This function makes the reactor object a 'persistent'
reactor (stored inside the dwg database).
Arguments
|
reactor (any reactor object) the reactor to make a
persistent reactor (stored inside dwg database)
|
Return
|
returns the
reactor object, or
NIL
|
Example
|
(setq rx (vlr-object-reactor
nil nil '((:vlr-modified . cb))))
#<VLR-Object-Reactor>
(setq obj (vlax-ename->vla-object
(entlast))) #<VLA-OBJECT IAcadLine
00000000427C86C0>
(vlr-owner-add rx obj) #<VLA-OBJECT
IAcadLine 00000000427C86C0>
(vlr-pers rx)
#<VLR-Object-Reactor>
"rx" object reactor is now persistent in the
drawing database
|
Remarks
|
Note :
if a drawing with persistent reactors is
opened on a CAD system, where the associated reactor event
handler(s) is not available (i.e. the Lisp or ARX/BRX code is not
available), the missing event handler will trigger error/warning
messages;
such can be annoying, and also slow-down
overall performance (depending on reactor type)
see also (vlr-pers-p) and
(vlr-pers-list)
functions
|