vlr-remove-all


(vlr-remove-all [ reactorType ] )

This function disables all reactors of specified reactorType.

Arguments

reactorType  (reactor type, optional)  the type of reactors to be disabled; if omitted or NIL, all reactive reactors are disabled;

can be one of these reactor types (or NIL) :
:VLR-AcDb-Reactor
:VLR-Command-Reactor
:VLR-DeepClone-Reactor
:VLR-DocManager-Reactor
:VLR-DWG-Reactor
:VLR-DXF-Reactor
:VLR-Editor-Reactor
:VLR-Insert-Reactor
:VLR-Linker-Reactor
:VLR-Lisp-Reactor
:VLR-Miscellaneous-Reactor
:VLR-Mouse-Reactor
:VLR-Object-Reactor
:VLR-SysVar-Reactor
:VLR-Toolbar-Reactor
:VLR-Undo-Reactor
:VLR-Wblock-Reactor
:VLR-Window-Reactor
:VLR-XREF-Reactor

Return

returns a list of sub-lists using the format :
( (reactorType reactor1 reactor2 ...) (reactorType reactor1 reactor2 ...) ...)
specifying all reactors that were disabled

Example

(vlr-remove-all)  disables all active reactors, returns
(
(:VLR-AcDb-Reactor #<VLR-AcDb-Reactor> #<VLR-AcDb-Reactor>)
(:VLR-Command-Reactor #<VLR-Command-Reactor>)
)

Remarks

see (vlr-add) and (vlr-added-p) and (vlr-remove) functions



©  Bricsys NV. All rights reserved.