write-char


(write-char number [ fileHandle ] )

This function writes the number character to command line or specified file fileHandle.

Arguments

number  (integer) the numerical value of the character to be written (to command line or file)
fileHandle  (file handle, optional) the file handle of an opened file; if omitted, output is sent to command line

Return

returns the number value

Example

(write-char 65)  A 65  writes the "A" character to command line
(write-char 65 fhandle)  65  writes the "A" character to the specified file

Remarks

the 0 character can only be written to a file, which is opened in "binary" mode, see (open) function



©  Bricsys NV. All rights reserved.