Represents the pixel organization scheme of
the source image file.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration ImageOrg
public enum class ImageOrg
Members
Member name |
Value |
Description |
Bitonal |
0 |
1 bit per pixel. |
Palette |
1 |
Palette that uses 8 bits per pixel. |
Gray |
2 |
8 bits per pixel grayscale where 0 is black and 255 is
white. |
RGBA |
3 |
32 bits, red-green-blue-alpha. |
BGRA |
4 |
32 bits, blue-green-red-alpha. |
ARGB |
5 |
32 bits, alpha-red-green-blue. |
ABGR |
6 |
32 bits, alpha-blue-green-red. |
BGR |
7 |
24 bits, blue-green-red. |
RGB |
8 |
24 bits, red-green-blue. |
See Also