EdgeModifiers Enumeration

Represents a collection of modifiers that can be applied to edges to give them various effects.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum EdgeModifiers
Members
Member name Value Description
None 0 No modifiers are applied.
Overhang 1 Allow an edge to overhang its start and end points by a specified amount.
Jitter 2 Apply a jitter effect to the edges. The jitter effect is produced by drawing extra lines adjacent to the original line, with a specific amount of perturbation away from the original line.
Width 4 Apply a width to the edges.
Color 8 Apply a color that differs from the drawable object color to the edges.
HaloGap 16 Apply a halo gap percentage to the edges of an object that is hidden by another object, such that the specified gap is displayed between the edges of the hidden object and the edges of the object which hides it.
Linetype 32 Apply a linetype to the edges.
AlwaysOnTop 64 Force edges to be on top. Edges will not participate in the Z-ordering of the displayed drawables.
Opacity 128 Apply an opacity value to the edges. If unset, edges display with full opacity. If set, edges display with a specified degree of opacity from completely opaque to completely transparent.
See Also

©  Bricsys NV. All rights reserved.