FaceColorMode Enumeration

Property that represents modifications that affect the color of a face before any lighting and shading calculations are performed.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum FaceColorMode
Members
Member name Value Description
None 0 Apply no modifications to the faces.
ObjectColor 1 Apply the color of the drawable object to the faces of the object.
BackgroundColor 2 Apply the display background color to the faces.
Mono 3 All faces are treated as having a specific color, resulting in a "monochromatic" effect.
Tint 4 All faces have the hue and saturation values of their color mapped to the hue and saturation values of a specific color, resulting in a "tinted" effect. The luminance value remains unchanged.
Desaturate 5 Apply a desaturation percentage for the diffuse color of a material.
See Also

©  Bricsys NV. All rights reserved.