VisualStyleType Enumeration

Represents predefined types of visual styles. Each predefined visual style type involves multiple visual style properties for the VisualStyleProperty enumeration. For more information, see Working with Visual Styles.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum VisualStyleType
Members
Member name Value Description
Flat 0 Flat shaded visual style.
FlatWithEdges 1 Flat shaded visual style with edges displayed.
Gouraud 2 Gouraud shaded visual style.
GouraudWithEdges 3 Gouraud shaded visual style with edges displayed.
Wireframe2D 4 2D wireframe visual style (using a 2D graphics system).
Wireframe3D 5 3D wireframe visual style (using a 3D graphics system).
Hidden 6 Hidden visual style.
Basic 7 Basic visual style (default).
Realistic 8 Phong shaded visual style.
Conceptual 9 Conceptual visual style.
Custom 10 Custom, user-defined visual style.
Dim 11 Visual style used for a dimming effect.
Brighten 12 Visual style used for a brightening effect.
Thicken 13 Visual style used for a thickening effect.
LinePattern 14 Visual style used to apply a line pattern.
FacePattern 15 Visual style used to apply a face pattern.
ColorChange 16 Visual style used to apply a change of color.
See Also

©  Bricsys NV. All rights reserved.