ScaleBehavior Enumeration
|
Specifies the position transform behavior of
transient graphics.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum ScaleBehavior
Public Enumeration ScaleBehavior
public enum class ScaleBehavior
Members
Member name |
Value |
Description |
World |
0 |
>Performs transforms in world space (default behavior). |
Viewport |
1 |
This is a normalized viewport 2D coordinate system, with X and
Y in the range [0.0 .. 1.0] and with (0.0, 0.0) at the lower left
corner and (1.0, 1.0) at the upper right. |
Screen |
2 |
Scales the geometry in absolute pixels. |
ViewportLocalOrigin |
3 |
Same as Viewport but for the 3D local coordinate system. |
ScreenLocalOrigin |
4 |
Scales the geometry in absolute pixels by setting a 2D position
for the 3D local coordinate system. |
See Also