AttributesFlags Enumeration
|
Attribute flags for a drawable.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum AttributesFlags
Public Enumeration AttributesFlags
public enum class AttributesFlags
Members
Member name |
Value |
Description |
DrawableNone |
0 |
Default flags; the drawable object uses only OdGi primitives,
with no nested calls to draw(). |
DrawableIsAnEntity |
1 |
Classes derived from OdDbEntity must set this flag, which is
set by the default implementation of
OdDbEntity::subSetAttributes(). |
DrawableUsesNesting |
2 |
The drawable uses nested calls to draw(), but makes no calls to
other OdGi primatives. |
DrawableIsCompoundObject |
4 |
The drawable is to be treated as a block. Valid only when
combined with kDrawableIsAnEntity. If set, you must override
OdDbEntity::getCompoundObjectTransform(). |
DrawableViewIndependentViewportDraw |
8 |
Currently not supported. |
DrawableIsInvisible |
16 |
Object is invisible and should not be rendered. |
DrawableHasAttributes |
32 |
Currently not supported. |
DrawableRegenTypeDependantGeometry |
64 |
This flag must be set for objects that are drawn differently in
different regen type modes. |
DrawableIsDimension |
133 |
Dimension objects must set these flags, which are set by the
default implementation of OdDbDimension. |
DrawableRegenDraw |
256 |
The drawable must always be regenerated. |
LastFlag |
65,536 |
Last flag in this enumeration. |
See Also