Defines the current type set to an Variant
object.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration VariantType
public enum class VariantType
Members
Member name |
Value |
Description |
Undefined |
0 |
Variant type is undefined (the default type). |
Boolean |
1 |
Variant is of a Boolean type (bool). |
Int |
2 |
Variant is of a long type (OdInt32). |
Double |
3 |
Variant is of a double type (double). |
Color |
4 |
Variant is of a color type (OdCmEntityColor). |
String |
5 |
Variant is of a string type (OdString). |
Table |
6 |
Variant is a table of key/value pairs. |
See Also