IntervalIsOverlapAtUpper
Method
|
Checks whether the upper bounds of the
specified interval and this interval are equal.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsOverlapAtUpper(
Interval otherInterval,
Interval overlap
)
Public Function IsOverlapAtUpper (
otherInterval As Interval,
overlap As Interval
) As Boolean
public:
bool IsOverlapAtUpper(
Interval^ otherInterval,
Interval^ overlap
)
member IsOverlapAtUpper :
otherInterval : Interval *
overlap : Interval -> bool
Parameters
- otherInterval Interval
- [in] Interval to test.
- overlap Interval
- [out] Receives the overlap of the intervals.
Return Value
Boolean
true only if all the following conditions are met: * This interval
is bounded above, and otherInterval is bounded below. * Neither
interval is a singleton. * The intervals intersect. * otherInterval
does not contain this one. * The upper bound of this interval is
contained in otherInterval. * The lower bound of otherInterval is
contained within this one. The 'overlap' parameter receives a valid
overlap interval only if this method returns true.
See Also