WallCutLineAnchorOffsetType
Enumeration
|
This enumeration represents relative positions
of an anchor.
Namespace: Teigha.Aec.Arch.DatabaseServices
Assembly: TA_MgdArch (in TA_MgdArch.dll)
Version: 0.0.0.0
Syntax
public enum WallCutLineAnchorOffsetType
Public Enumeration WallCutLineAnchorOffsetType
public enum class WallCutLineAnchorOffsetType
type WallCutLineAnchorOffsetType
Members
Member name |
Value |
Description |
FromWallStart |
0 |
Location is measured from wall start. |
FromWallEnd |
1 |
Location is measured from wall end. |
FromBaseline |
2 |
Location is measured from base line of the wall. |
FromWallMidpoint |
3 |
Location is measured from wall mid point. |
FromPreviousAnchor |
4 |
Location is measured from the location of previous anchor. |
FromNextAnchor |
5 |
Location is measured from the location of next anchor. |
FromMidpointOfNeighbors |
6 |
Location is measured from the average of locations of
neighboring anchors. |
FromBaseHeight |
7 |
Location is measured from base height of the wall. |
See Also