PositionBehavior Enumeration

Specifies the position transform behavior of transient graphics.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum PositionBehavior
Members
Member name Value Description
World 0 Performs transforms in world space (default behavior).
Viewport 1 Uses a normalized viewport 2D coordinate system, with X and Y in the range [0.0 .. 1.0] and with (0.0, 0.0) at the lower left corner and (1.0, 1.0) at the upper right.
Screen 2 Positions the geometry in absolute pixels.
ScreenLocalOrigin 3 Positions the geometry in absolute pixels by setting a 2D position for the 3D local coordinate system.
WorldWithScreenOffset 4 Performs positioning in world space with a screen space pixel offset. For example, used for an annotation or label that should track a world point.
See Also

©  Bricsys NV. All rights reserved.