LightingQuality Enumeration
|
Represents the calculation methods used for
the application of lighting effects to faces.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum LightingQuality
Public Enumeration LightingQuality
public enum class LightingQuality
Members
Member name |
Value |
Description |
NoLighting |
0 |
No lighting calculations are applied to the faces. |
PerFaceLighting |
1 |
Color is calculated for each face based on its orientation to
the light sources of the scene. |
PerVertexLighting |
2 |
Color is calculated for each vertex of a face based on its
orientation to the light sources of the scene. |
See Also