DrawableTraitsAddLight
Method
|
Drawables that emit light are able to append
one or more "lights" to the model. The default implementation of
this method ignores the passed light. Must be implemented in
derived classes.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract void AddLight(
ObjectId lightId
)
Public MustOverride Sub AddLight (
lightId As ObjectId
)
public:
virtual void AddLight(
ObjectId lightId
) abstract
abstract AddLight :
lightId : ObjectId -> unit
Parameters
- lightId ObjectId
- [in] Entity for which to set up traits.
See Also