BrepHasTransformation Method
|
Checks if this B-Rep has a transformation
matrix that transforms this B-Rep (non-identity matrix).
Namespace: Teigha.BoundaryRepresentation
Assembly: TD_MgdBrep (in TD_MgdBrep.dll)
Version: 0.0.0.0
Syntax
public bool HasTransformation(
out Matrix3d matrix
)
Public Function HasTransformation (
<OutAttribute> ByRef matrix As Matrix3d
) As Boolean
public:
bool HasTransformation(
[OutAttribute] Matrix3d% matrix
)
member HasTransformation :
matrix : Matrix3d byref -> bool
Parameters
- matrix Matrix3d
- [in] Receives the transformation matrix.
Return Value
Boolean
true if this B-Rep has a non-identity
transformation matrix.
See Also