Constructor for the Matrix3d class. Creates a
matrix with elements taken from the passed array.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Matrix3d(
double[] data
)
Public Sub New (
data As Double()
)
public:
Matrix3d(
array<double>^ data
)
new :
data : float[] -> Matrix3d
Parameters
- data Double
- [in] Array of values for the matrix.
Remarks
Matrix is assigned
the first 16 elements of the specified array (matrix in homogeneous
coordinates). Matrix elements are set by rows (data11, data12 ...
data44).
See Also