DrawableType Enumeration

This class represents known types of drawable objects.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum DrawableType
Members
Member name Value Description
Geometry 0 Geometry.
DistantLight 1 Distant light.
PointLight 2 Point light.
SpotLight 3 Spot light.
AmbientLight 4 Ambient light.
SolidBackground 5 Solid background light.
GradientBackground 6 Gradient background.
ImageBackground 7 Image background.
GroundPlaneBackground 8 Ground plane background.
Viewport 9 Viewport.
WebLight 10 Web light.
SkyBackground 11 Sky background.
ImageBasedLightingBackground 12 Image-based lighting background.
See Also

©  Bricsys NV. All rights reserved.