IntervalIsPeriodicallyOn Method

Checks whether the specified value is periodic on this interval.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsPeriodicallyOn(
        double period,
        out double value
)

Parameters

period  Double
[in] Period.
value  Double
[in/out] Value.

Return Value

Boolean
true if there is a positive integer N such that value + N * period is on this interval. If so, returns that value as the 'value' parameter.
See Also

©  Bricsys NV. All rights reserved.