OrientationBehavior Enumeration
|
Specifies the orientation transform behavior
of transient graphics.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum OrientationBehavior
Public Enumeration OrientationBehavior
public enum class OrientationBehavior
Members
Member name |
Value |
Description |
World |
0 |
Transformations are made in world space. |
Screen |
1 |
Orients the geometry to the screen plane regardless of WCS
orientation. |
ZAxis |
2 |
This is an orientation to the screen except for the z-axis
which follows the WCS z-axis rotation. |
See Also