ChannelFlags Enumeration

Specifies material channels.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
[FlagsAttribute]
public enum ChannelFlags
Members
Member name Value Description
None 0 No material channels enabled.
UseDiffuse 1 Enables the diffuse material channel.
UseSpecular 2 Enables the specular material channel.
UseReflection 4 Enables the reflection material channel.
UseOpacity 8 Enables the opacity material channel.
UseBump 16 Enables the bump material channel.
UseRefraction 32 Enables the refraction material channel.
UseNormalMap 64 Enables the normal map material channel.
UseAll 127 Enables all material channels.
See Also

©  Bricsys NV. All rights reserved.