IlluminationModel Enumeration
|
This enumeration specifies the illumination
mode used in the rendering process when working with
materials.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum IlluminationModel
Public Enumeration IlluminationModel
public enum class IlluminationModel
Members
Member name |
Value |
Description |
BlinnShader |
0 |
Blinn shader which uses the light's color to determine the
reflection color. |
MetalShader |
1 |
Metal shader which calculates the reflected light's color using
the material's diffuse color and the light's color. |
See Also