AttenuationType Enumeration
|
Represents attenuation types for lights.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum AttenuationType
Public Enumeration AttenuationType
public enum class AttenuationType
Members
Member name |
Value |
Description |
None |
0 |
No attenuation is used. |
InverseLinear |
1 |
Light intensity equals the inverse of the linear distance from
the light source. |
InverseSquare |
2 |
Light intensity equals the inverse of the square distance from
the light source. This type of attenuation is the most physically
accurate. |
See Also