NurbCurve2dDataInequality Operator

Inequality operator for the NurbCurve2dData structure. Checks whether curve data is not equal.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static bool operator !=(
        NurbCurve2dData a,
        NurbCurve2dData b
)

Parameters

a  NurbCurve2dData
[in] Left curve data to compare.
b  NurbCurve2dData
[in] Right curve data to compare.

Return Value

Boolean
true if at least one of the following conditions fails: * Both curves are rational (weight values applied) or not rational (weight values are not applied) * Both curves are periodic (closed) or not periodic (open) * Control points are equal * Knot collections are equal * Weight values are equal
See Also

©  Bricsys NV. All rights reserved.