DiagnosticMode Enumeration
|
Represents available diagnostic visualization
modes.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum DiagnosticMode
Public Enumeration DiagnosticMode
public enum class DiagnosticMode
Members
Member name |
Value |
Description |
Off |
0 |
Render normally. |
Grid |
1 |
Render a grid on top of all objects in the scene using the
coordinate system specified with a value from the
DiagnosticGridMode enum. |
Photon |
2 |
Render a false-color image of photon density or photon
irradiance on all surfaces, as specified with a value from the
DiagnosticPhotonMode enum. Higher density or irradiance is shown
with red, and lower values are represented with blue. |
Samples |
3 |
Render a grayscale image illustrating sample density, which is
controlled with the MentalRayRenderSettingsTraits.Sampling
property. Higher levels of sampling are shown with brighter shades
of gray. |
BSP |
4 |
Render a false-color image illustrating the cost of creating
and traversing the BSP tree used for ray-tracing. Both the depth
and the leaf size can be visualized, as specified with a value from
the DiagnosticBSPMode enum. |
See Also