Transparency Structure

Wraps OdCmTransparency class. Implements Transparency objects, which provide transparency information about Drawable objects.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.ColorsTransparency

Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Transparency

The Transparency type exposes the following members.

Constructors
  Name Description
Public method Transparency(Byte) Builds an instance of the object using alpha value.
Public method Transparency(TransparencyMethod) Builds an instance of the object using transparency method.
Top
Properties
  Name Description
Public property Alpha Gets the alpha value for this object.
Public property IsByAlpha Gets if the transparency method is ByAlpha
Public property IsByBlock Gets if the transparency method is ByBlock
Public property IsByLayer Gets if the transparency method is ByLayer
Public property IsClear Gets if the transparency method for this Transparency object is ByALpha and alpha == 0.
Public property IsSolid Gets if the transparency method for this Transparency object is ByALpha and alpha == 255.
Top
Methods
  Name Description
Public method Equals Returns the truthness of the objects identity.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Returns hash code for this object.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns a string representation of this Object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns a string representation of this Object depending on UI culture defined by provider
Top
Operators
  Name Description
Public operatorStatic member Equality(Transparency, Transparency) Equal-To Operator
Public operatorStatic member Inequality(Transparency, Transparency) Not-Equal-To Operator
Top
See Also

©  Bricsys NV. All rights reserved.