SelectionMode Enumeration
|
Selection modes.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum SelectionMode
Public Enumeration SelectionMode
public enum class SelectionMode
Members
Member name |
Value |
Description |
Window |
0 |
Selection by two points (represents a rectangle). Select only
objects that are entirely inside the selection area. |
Crossing |
1 |
Selection by two points (represents a rectangle). Select
objects that are entirely inside or intersect the selection
area. |
Fence |
2 |
Selection by two or more points (represents a polyline). Select
an object that intersects the selection polyline. |
WPoly |
3 |
Selection by three or more points (represents a polygon).
Select only objects that are entirely inside the selection
area. |
CPoly |
4 |
Selection by three or more points (represents a polygon).
Select objects that are entirely inside or intersect the selection
area. |
Point |
16 |
Same as Crossing, but returns only a single selected object:
top for 3D render modes or first for 2D render mode. |
See Also