CoordinateSystem2d Structure

This .NET structure represents a 2D coordinate system that provides the origin point and directions of the positive X- and Y-axis.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryCoordinateSystem2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct CoordinateSystem2d : IFormattable

The CoordinateSystem2d type exposes the following members.

Constructors
  Name Description
Public method CoordinateSystem2d Constructor for the CoordinateSystem2d structure.
Top
Properties
  Name Description
Public property Origin  
Public property Xaxis  
Public property Yaxis  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(CoordinateSystem2d)  
Public method IsEqualTo(CoordinateSystem2d, Tolerance)  
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Public method ToString(String, IFormatProvider)  
Top
Operators
See Also

©  Bricsys NV. All rights reserved.