BimResStatus Enumeration


Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public enum BimResStatus
Members
Member name Value Description
Ok 0  
NoDbResidentObject 1  
DbNotAccessible 2  
DbObjectNotSupported 3  
DbNotOpenForWrite 4  
ModelSpaceNotAccessible 5  
ProjectDbNotAccessible 6  
AssociatedLibraryNotAccessible 7  
NotApplicableForTheseParameters 8  
InvalidSpatialLocation 9  
InvalidMaterial 10  
InvalidMaterialComposition 11  
ObjectAlreadyExists 12  
ObjectCouldNotBeDeleted 13  
XmlFileCouldNotBeParsed 14  
InvalidXmlFormat 15  
InvalidName 16  
NotLinearBuildingElement 17  
InvalidValue 18  
NotAssignedToLibrary 19  
NullObject 20  
NullObjectId 21  
NullDatabase 22  
NullDocument 23  
NullString 24  
ObjectNotExisting 25  
ObjectNotSupported 26  
NoProfileAssigned 27  
NoData 28  
UnknownData 29  
WrongDataType 30  
UnassignedEntity 31  
BimNotImplementedYet 32  
BimNotAvailable 33  
InternalError 34  
UnknownError 35  
InvalidIndex 36  
InvalidInput 37  
NoNameSpace 38  
NameSpaceAlreadyExists 39  
NoPropertySet 40  
PropertySetAlreadyExists 41  
NoProperty 42  
NotImplementedYet 43  
InvalidArgument 44  
See Also

©  Bricsys NV. All rights reserved.