NurbCurve2dDataIsEqualTo Method

Checks whether this NURBS curve data is equal to the passed NURBS curve data.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsEqualTo(
        NurbCurve2dData a
)

Parameters

a  NurbCurve2dData
[in] NURBS curve 2D data to compare.

Return Value

Boolean
true if all of the following conditions are met: * Both curves are rational (weight values applied) or not rational (weight values are not applied) * Both curves are periodic (closed) or not periodic (open) * Control points are equal * Knot collections are equal * Weight values are equal
See Also

©  Bricsys NV. All rights reserved.