VisualStyleProperty Enumeration

Defines the get/set properties for a visual style. For more information, see Working with Visual Styles.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum VisualStyleProperty
Members
Member name Value Description
FaceLightingModel 0 The lighting model applied to the faces of drawables. See the LightingModel enumeration.
FaceLightingQuality 1 The calculation method of lighting effects applied to faces. See the LightingQuality enumeration.
FaceColorMode 2 The color mode applied to faces. See the FaceColorMode enumeration.
FaceModifier 3 Modifications applied to faces. See the FaceModifiers enumeration.
FaceOpacity 4 The face opacity property. Double value representing the face opacity level in the range from 0.0 (faces are fully transparent) to 1.0 (no transparency).
FaceSpecular 5 The face specular property. Double value representing the specular highlight amount (indicating reflection and shininess values) of the material that is applied to faces.
FaceMonoColor 6 The face monocolor effect property. The Color object represents the color that is applied to produce a "monochromatic" effect on faces.
EdgeModel 7 The edge model property. See the EdgeModel enumeration.
EdgeStyle 8 The edge style property. See the EdgeVisibilityModes enumeration.
EdgeIntersectionColor 9 The color applied to intersected edges. OdCmColor representing the color applied to intersection edges.
InvalidProperty -1 Invalid property.
EdgeObscuredColor 10 The color applied to obscured edges. The Color object represents the color applied to obscured edges.
EdgeObscuredLinePattern 11 The line pattern applied to obscured edges. See the EdgeLinePattern enumeration.
EdgeIntersectionLinePattern 12 The line pattern applied to intersection edges. See the EdgeLinePattern enumeration.
EdgeCreaseAngle 13 The edge crease angle. Double value indicating the angle threshold, above which a facet edge representing adjoining facets is displayed.
EdgeModifier 14 Modifications applied to edges. See the EdgeModifiers enumeration.
EdgeColor 15 The edge color property. The Color object represents the color applied to edges.
EdgeOpacity 16 The edge opacity property. Double value representing the edge opacity level in the range from 0.0 (faces are fully transparent) to 1.0 (no transparency).
EdgeWidth 17 The edge width property. Integer value representing the edge width in pixels.
EdgeOverhang 18 The edge overhang property. Integer value representing the amount, in pixels, that edges should overhang their start and end points.
EdgeJitterAmount 19 The edge jitter amount. See the JitterAmount enumeration.
EdgeSilhouetteColor 20 The edge silhouette color property. OdCmColor enumeration the color applied to silhouette edges.
EdgeSilhouetteWidth 21 The edge silhouette width property. Short value representing silhouette the edge width in pixels.
EdgeHaloGap 22 The edge halo gap amount. Integer value from 0 to 100 representing the halo gap.
EdgeIsolines 23 The isolines number property. Unsigned short value, between 0 and 2047, indicating the number of isolines to display for curved surfaces.
EdgeHidePrecision 24 The hide precision property. Boolean value indicating whether hide precision is enabled. True if enabled; otherwise, false.
DisplayStyle 25 Display settings. See the DisplayStyles enumeration.
DisplayBrightness 26 The display brightness property. Double value indicating brightness.
DisplayShadowType 27 The display shadow type property. See the DisplayShadowType enumeration.
UseDrawOrder 28 Boolean value indicating whether draw order is enabled. True if enabled; otherwise, false.
ViewportTransparency 29 Boolean value indicating whether viewport transparency is enabled. True if enabled; otherwise, false.
LightingEnabled 30 Boolean value indicating whether lighting is enabled. True if enabled; otherwise, false.
PosterizeEffect 31 Boolean value indicating whether the posterize effect is enabled. True if enabled; otherwise, false.
MonoEffect 32 Boolean value indicating whether mono effect is enabled. True if enabled; otherwise, false.
BlurEffect 33 Boolean value indicating whether the blur effect is enabled. True if enabled; otherwise, false.
PencilEffect 34 Boolean value indicating whether the pencil effect is enabled. True if enabled; otherwise, false.
BloomEffect 35 Boolean value indicating whether the bloom effect is enabled. True if enabled; otherwise, false.
PastelEffect 36 Boolean value indicating whether pastel effect is enabled. True if enabled; otherwise, false.
BlurAmount 37 The blur amount property. Integer value representing the amount of blur effect.
PencilAngle 38 The pencil angle amount property. Double value representing the angle amount.
PencilScale 39 The pencil scale amount property. Double value representing the scale amount.
PencilPattern 40 The pencil pattern amount property. Integer value representing the pencil pattern.
PencilColor 41 The pencil color property. OdCmColor representing the pencil color.
BloomThreshold 42 The bloom effect threshold property. Integer value representing the threshold value.
BloomRadius 43 The bloom effect radius. Integer value representing the bloom radius.
TintColor 44 The tint color property. OdCmColor representing the color that is used for tint effect.
FaceAdjustment 45 Boolean value indicating whether face adjustment is enabled. True if enabled; otherwise, false.
PostContrast 46 The post-processing contrast property. Integer value representing the contrast value.
PostBrightness 47 The post-processing brightness property. Integer value representing the brightness value.
PostPower 48 Integer value.
TintEffect 49 Boolean value indicating whether the tint effect is enabled. True if enabled; otherwise, false.
BloomIntensity 50 The bloom intensity property. Integer value representing the intensity of the bloom effect.
Color 51 Color value.
Transparency 52 Transparency represented by a double value.
EdgeWiggleAmount 53 The edge wiggle amount property, where: * 1 - a small amount of perturbation. * 2 - a medium amount of perturbation. * 3 - a large amount of perturbation.
EdgeTexturePath 54 The edge texture path property. String value representing the path to the texture.
DepthOfField 55 Boolean value indicating whether the depth of field effect is enabled. True if enabled; otherwise, false.
FocusDistance 56 The focus distance property. Double value indicating the focus distance value.
FocusWidth 57 The focus width property. Double value indicating the focus width value.
PropertyCount 58 The number of visual style properties.
See Also

©  Bricsys NV. All rights reserved.