LightingModel Enumeration
|
Represents the lighting model for faces.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum LightingModel
Public Enumeration LightingModel
public enum class LightingModel
Members
Member name |
Value |
Description |
Invisible |
0 |
Faces are invisible. |
Constant |
1 |
Faces are drawn in a constant color. |
Phong |
2 |
Faces are drawn with the Phong model to approximate realistic
direct lighting. |
Gooch |
3 |
Faces are drawn with a non-photorealistic lighting model for
automatic technical illustration. |
See Also