AddPolyfaceMesh method
Creates a new polyface mesh object and adds it to the
drawing.
Syntax
objectVariable =
object.AddPolyfaceMesh(VerticesList,
FacesList)
Where:
object
is one of the ModelSpace or PaperSpace collection objects or a
Block object;
VerticesList a
Variant (array of doubles). This is an array of 3D WCS coordinates
used to create the polyface mesh vertices. At least four points
(twelve elements) are required for constructing a polyface mesh
object. The array size must be a multiple of three.
FacesList a
Variant (array of Integers). This is an array of integers
representing the vertex numbers for each face. Faces are defined in
groups of four vertex index values, so the size of this array must
be a multiple of four.
Examples...
AddPolyfaceMesh method
example
© Bricsys NV. All rights reserved. |