Class AcadDocument
Member of BricscadApp
The Document object represents the active BricsCAD drawing. The active document (BricsCAD drawing) can be accessed using ThisDrawing in VBA or through the ActiveDocument property in VB.
To create or open a Document object, use the New or Open methods. To edit or query a Document object, use the following methods, properties and events:
Methods | Properties | Events |
---|---|---|
Activate | Active | Activate |
AuditInfo | ActiveDimStyle | BeginClose |
Close | ActiveLayer | BeginCommand |
CopyObjects | ActiveLayout | BeginDocClose |
EndUndoMark | ActiveLinetype | BeginDoubleClick |
Export | ActivePViewport | BeginLisp |
GetVariable | ActiveSelectionSet | BeginPlot |
HandleToObject | ActiveSpace | BeginRightClick |
Import | ActiveTextStyle | BeginSave |
LoadShapeFile | ActiveUCS | BeginShortcutMenuCommand |
New | ActiveViewport | BeginShortcutMenuDefault |
ObjectIdToObject | Application | BeginShortcutMenuEdit |
PurgeAll | Blocks | BeginShortcutMenuGrip |
Regen | Database | BeginShortcutMenuOsnap |
Save | Dictionaries | Deactivate |
SaveAs | DimStyles | EndCommand |
SendCommand | ElevationModelSpace | EndLisp |
SetVariable | ElevationPaperSpace | EndPlot |
StartUndoMark | FileDependencies | EndSave |
Wblock | FullName | EndShortcutMenu |
Groups | LayoutSwitched | |
Height | LispCancelled | |
HWND | ObjectAdded | |
Layers | ObjectErased | |
Layouts | ObjectModified | |
Limits | SelectionChanged | |
Linetypes | WindowChanged | |
Materials | WindowMovedOrResized | |
ModelSpace | ||
MSpace | ||
Name | ||
ObjectSnapMode | ||
PaperSpace | ||
Path | ||
PickfirstSelectionSet | ||
Plot | ||
PlotConfigurations | ||
Preferences | ||
ReadOnly | ||
RegisteredApplications | ||
Saved | ||
SectionManager | ||
SelectionSets | ||
SummaryInfo | ||
Textstyles | ||
UserCoordinateSystems | ||
Utility | ||
Viewports | ||
Views | ||
Width | ||
WindowState | ||
WindowTitle |
© Bricsys NV. All rights reserved. |