acet-lwpline-make


(acet-lwpline-make  inplist)

Creates a LWPOYLINE entity based in inplist data;
inplist must be a list of format (defaults points).

defaults : is a list of (dxf . value) pairs, specifying desired standard properties like color, layer etc.; can be NIL
points : is a list of 2d or 3d points

Returns nothing (like (princ) function).

Example :
   (setq defaults (list (cons 70 1) (cons 62 4) (cons 43 2)))

   (setq points (list '(0 0 0) '(5 5 5) '(10 0 0)))

   (acet-lwpline-make (list defaults points))

Create a closed LWPOYLINE with color cyan and global width 2, using 3 points.


©  Bricsys NV. All rights reserved.