acet-str-replace
(acet-str-replace oldStr newStr
inString [caseInsensitive [wildcardMatch
[numReplaces]]])
Returns the result string from
replacing oldStr with string newStr
in string inString;
if caseInsensitive is provided
and non-NIL, the replacement is performed in case-insensitive
mode;
if wildcardMatch is provided and
non-NIL, the replacement is performed in regular expression
mode;
if numReplaces is provided and
non-NIL, the replacement is performed numReplaces times, if omitted,
any occurrence is replaced.
these special characters are supported for
replacements wildcardMatch
:
|
. (dot) |
replaces any single character |
|
* (asterisk) |
replaces any sequence of characters |
|
+ |
|
|
^ |
matches the begin-of-inString (matches are only accepted at end of inString) |
|
$ |
matches the end-of-inString (matches are only accepted at begin of inString) |
|
[charset] |
matches any characters as specified by "charset"; the brackets indicate the character set |
|
\( |
indicates the begin of a sub-expression |
|
\) |
indicates the end of a sub-expression |
|
\number |
"repeat count" for last matched character |
© Bricsys NV. All rights reserved. |