bim:delete-attributesets
(bim:delete-attributesets [categoryId |
categoryName])
This functions removes all AttributeSets, from
the (optionally) specified NameSpace.
Arguments
|
(optional)
specifies the NameSpace to remove all
AttributeSets from (each category has an associated
NameSpace)
categoryId BIM property category ID, can be omitted
(bcBimCategoryUser is used then); see Category Constants
---or---
categoryName BIM property category name as string, can be omitted
(bcBimCategoryUser is used then), see Category Constants
if omitted, the "User" NameSpace is
automatically used to search for all AttributeSets
|
Return
|
T or NIL, indicating success
or failure
|
Example
|
(bim:create-attributeset
"---testName---" "---testLabel---" T) T
(bim:has-attributeset "---testName---")
T
(bim:delete-attributesets) T
(bim:has-attributeset "---testName---")
NIL
(bim:delete-attributesets) T
|
Remarks
|
the BIM property category
name is case sensitive;
if the NameSpace (as indirectly specified by
categoryId resp. categoryName) does not exist, it will be
automatically created, as a visible NameSpace
|